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� If you're asking yourself �What is this?�, well, it is my own quick LYX instructions. Every time I learn
a new trick, I write it down here - before I forget. Some of it I read from the LYX help, some from
friends, or from wiki LYX. But the best was the amazing, friendly, "General Users' list: lyx-users".

� I am surprised how popular this document had become, which motivates me to clean it up and make
it more reader friendly. Hopefully you can also �nd this LYX Tricks useful.

� IMPORTANT: If you are now reading the PDF output, you might �nd it much more useful to
download the LYX �le from my webpage, because you can then just copy and paste commands into
your own document. You won't really understand this instructions by looking at the PDF on its own.

� LYX combines the power and �exibility of TEX/LATEX with the ease of use of a graphical interface:
www.lyx.org.

� I would like to thank the LYX developers.

∗I would like to thank the LYX developers for writing this program and for the various users in the lyx forum that answer
questions. www.lyx.org
†Copyright© Erez Yerushalmi 2010, http://go.warwick.ac.uk/ep/pg/ecrfaw
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1 Latex Short Hand Symbols

Some commands that, today, I use intuitively. You can learn commands along the way by looking a the
command bu�er on the lower-left corner in LYX.

1. cntl-M ��starts math

2. shift-control - M ��place math in center

3. contro-alt N ��place math in center with #

4. \cdot ·

5. \alpha α

6. \partial ∂

7. \prime ′

8. \not= 6=

9. \cong ∼= �equal and similar� or �congruent.�

10. \approx ≈

11. \mathbb ARetc.

1. Cntl-M Alt-M ( shift-9 (�)

2. \frac �
�

3. ^ ��

4. \underset �
�

5. \overset
�
�

6. Cntl-E emphasis in most styles will be italic

7. Multi-line formulas are created when you press \cases then C-Enter. You can add or delete columns

or lines using the special buttons.

{
� �

� �
or easily

{
�

�

8. Insert . Math . Cases Environment or the command \cases.

9. Edit . Math . Toggle Numbering or the shortcut Cntrl M-m n.

10. Multi-line numbering can be done line by line: Using the menu Edit . Math . Toggle Numbering of
Line OR the shortcut M-m N will only toggle the numbering of the line where the cursor is.

11. small space \, gives a forced skip. You can decide its length by the # of presses, though limited in
length.

12. medium space \;

13. med-large space \quad

14. \qquad
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15. \mbox - but the easiest is Cntrl-M, then Cntrl-M again, type your regular text, space, then you will
go back to math mode.

16. \boxed Aα+B Inside is a math formula \boxed{A\alpha+B}

17. \fbox regular text Inside a math box, you get regular text

18. \forall ∀

19. \ldots . . .

20. \sum_t=0 space ^\infty in a line gives
∑∞

t=0

21. If you write this in a numbered equation
∞∑
t=0

(1)

22. \times ×

2 General Things

� Dictionary: Changing Dictionary from English US to English UK, Document>settings>language

2.1 Saving LYX documents

� When I save a LYX document, I work within a folder.

� The LYX �le, and all the other �les connected to the �le, are in the same folder.

� When I send a document to a co-author, I zip the folder up because the LYX document is linked to
the �gures and bibtex. The document will crash without all these together.

� For example, when I move from version 1 to version 2, I copy and rename the folder, not only document.
Obviously, you could have multiple versions of the LYX �le, within the same folder. Then, all �gures
and bibtex are still linked to the �les. This is also another strategy you could use.

� Word documents do that for us.

2.2 Webpages

1. a good place to learn latex code�
http://www-h.eng.cam.ac.uk/help/tpl/textprocessing/teTEX/latex/latex2e-html/ltx-3.html

2.3 Numbering Equations and Figures

1. To number equation, go to: Edit→Math→Number whole or number line

2. To number equation by sections, go to document preamble and drop in \usepackage{amsmath} and
\numberwithin{equation}{section} . Go to Document Preamble go to: Document→settings →latex
preamble

3. Place in preamle: \numberwithin{equation}{section} and for �gures \numberwithin{�gure}{section}.
IMPORTANT: need to go to Document > Settings... > Math Options, uncheck "Use AMS math
package automatically" and check "Use AMS math package" instead, and it will work.
Alternatively, just place in preamble: \usepackage{amsmath}

4. To label go to Insert:Label
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5. Insert cross reference.

6. QUICK make line numbering cnrl-alt-n

7. I want to start with an equation, do the calculation on the right side, and end up with the solution
and an equation number at the end.

8. For example, I begin with insert equation with a number by using cnrl-alt-n Then I use cnrl-enter to
create the next equations (like a matrix). to have a number only in the end of the equations, all I do
is go to the end of the equations I don't want to be numbered and delete the number.

2.4 Inserting Figures

1. Press insert �gure �oat

2. In the little box, place title

3. Above or below, insert > graphics

4. Mark with 'blue' around the graphics, go to edit> paragraph settings>center, or quicker, go directly
to �paragraph settings button.

2.4.1 The following is a way to place �gures side by side

One Figure

� Insert �gure �oat (either by pressing button or by insert)

� Insert minipage (press 'insert b\gamma+\betaox button' or insert>box)

� Insert > Formatting > Horizontal Fill

� Insert graphics

� Right mouse click and obtain extra settings: example, �prefer �gure here�

Figure 1: One �gure
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Two Figures

Figure 2: Float on the left side.
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Figure 3: Float on the right side.

************************
Three Figures

Figure 4: Case 1 Figure 5: Case 2
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Figure 6: Case 3
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set box setting: width according to how many pics in a row. If three, then 33%.
set graphics setting: width is 100; column width

2.5 Tables

From Excel. Build a second lyx work sheet. Between each column, place & and closing column \\
In Lyx doc. Float:table,
\begin{tabular} { add here l or c or r }, each column needs either: l (left) c (center) r (right)
\hline a new horizontal line - will draw a line above and below.
To draw a vertical line, within the tablar place a | .
& is a break in column - jumps to the new column
\\ end of line, any code after that is on the next line.
If using a %, you must place \% , because latex then thinks it is a comment.
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Table 1: test table

Year Observations
1995 59,994
1996 62,573
1997 67,928
1998 71,835
1999 74,782
2000 74,648
2001 78,194
2002 84,147
2003 87,429
2004 88,453
2005 89,679
2006 92,507
2007 93,130

Table 2: test table

Year Observations
Water Quantity MCM

2005
% of total Expenditure NIS/MCM

Agriculture 543.7 41% 1111.7 2.0
Non-Agriculture 85.1 6% 378.5 4.4
Household 710.4 53% 3448.8 4.9

2.6 Other Tricks

1. Importing from Scienti�c Work Place(SWP) see: http://wiki.lyx.org/FAQ/ImportingFromSWP

2. If you want in �Enumerate� to have the �rst line with the #, then the next line under, but no #, press
control-enter.
�like I did now�.

3. Find and Replace. If you want to replace math, then save lyx backup. Open up the original �le in my
favourite note pad, and replace.

4. To Start Appendix : Document>Start Appendix Here

5. ERT [\begin{appendices}]
ERT [\end{appendices}]

6. To prevent Lyx from centering numbered equations: use the �eqn option in the Document Class under
Settings. This left-justi�es the equations,

7. Forcing a section (and all below it) to start on a di�erent number. Just place in ERT \setcounter{section}{1}
before the section, and it will start counting from 2.

8. How can I get rid of the headings out of some pages?
You can use the ERT command \pagestyle{plain} before the list of �gures command.
Then put \pagestyle{headings} (or \pagestyle{fancy} if you were using fancyhdr) in ERT somewhere
in the page where you want to resume headings.
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9. To make the text: "Table of Contents" appears in the Center of the screen? (Just the Title) By default
it is shown aligned to the Left.
\renewcommand\contentsname{\center Table of Contents}

2.7 Bibliography/Reference

To start a bibliography, I use a bibtex �le which I place in my literature folder. This bibtex �le is created
with Zotero.

In LYX, I point to this �le and cite from it.
Zotero/LyZ update my bibtex �le whenever I have new references to add.

2.8 Citing with Zotero/LyZ

1. Zotero is an add-on to Firefox

2. LyZ is a plug-in that connects Zotero and LYX.

3. Instructions see: http://www.klubko.net/?page_id=945&lang=en

4. With Zotero I store my bibliography and update my bibtex �le. I can also do mind-mapping with it.
Check out VUE.

5. Open LYX, but have no document open.

(a) Set LYXServer path (in LYX go to menu, Tools > Preferences... > Inputs > Paths and set
LYXServer path to):

(b) Windows users can use the default path setting in LyZ, i.e. �\\.\pipe\lyxpipe�.

(c) Linux and Mac users can use e.g. �~/.lyxpipe� and change the LyZ settings accordingly.

2.9 Starting a new Reference in a New Document

1. Go to the place in your document where you want the references to be presented (presumably, the
end. You can also have reference at the end of each section). Click Insert/ Lists & TOC/ BibTEX
Bibliography. LYX opens a menu-X..

2. In the Menu-X, add > (a new menu-Y comes up) browse > look for the XXX.bib �le where your
bibliography is stored. Press Add, then OK. Menu-Y closes. You can add multiple libraries...

3. Back in Menu-X, change style to klunamed.

4. See various styles in http://www.mackichan.com/index.html?techtalk/632.htm~mainFrame

2.10 Citing

1. Click LYX's Layout/Document setting, choose Bibliography. Here you specify the style of citations you
want. (I chose klunamed)

2. Choose author-year citation format, so click the �Use NatBib� button. And save your settings. Warning:
NatBib will not work with all bibliography styles.

3. It works with: apalike, klunamed, apsa etc.

4. Now, suppose you are writing a document and you want to cite something. Click LYX's �Insert/ Citation
button. A menu should open and you should see the list of reference �keys� in the column on the right.
LYX should have read your bib �le and found all of the items.

5. You could also cite through Zotero/LyZ

6. bst �les located in C:\Program Files\MiKTEX 2.7\bibtex\bst

In Zotero, the LyZ button enables me to cite directy from Zotero.
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2.11 Acknoweldgements

\begin{acknowledgement}
\end{acknowledgement}

2.12 Header + Footer

Go to Document>page layout
change page sytle to �fancy�
In the preamble, you need to cancel what you don't want to be show by overriding it with an empty

command.
\rhead{} cancels right header
\chead{} cancels right header
\lhead{Erez Yerushalmi} adds My name.
\rhead{Section \thesection} or \thesubsection etc. gives 'Section 2' etcc.
Discovered a Problem: Header still goes by default small page, even though in the preamble I asked LYX

to have the MS-O�ce defaults. In order to make it work, in Tools>Setting>Page margins, need to put
margins in manualy.

Here is how you control the font size in the header/footer using fancyhdr.
Note that you can do that for each portion of the header or footer independently.
\usepackage{fancyhdr} \pagestyle{fancy}
\lhead{\scriptsize \textsf{Principal Investigator/Program Director (Last, First, Middle)}} %left header
\chead{} %Leave the center of the header empty \rhead{Adrian} %Display this text on the right of the

header
\lfoot{\scriptsize \textsf{PHS 398 (Rev. 05/01)}} %Display this text on the left of the footer
\cfoot{Page \ \thepage} % Print the page number in the center of the footer
\rfoot{\scriptsize \textsf{Continuation Format Page}} %right footer
\renewcommand{\headrulewidth}{0.4pt} %print a rule below the header
\renewcommand{\footrulewidth}{0.4pt} %print a rule above the footer

2.13 Subtitle

A brutal solution is to put the subtitle in the title and separate it by hard-enters (Ctrl-Enter in LYX) and
make it smaller by _brutal force_

3 Ready Made Structures: Plug and Play

ρ density
V volume
g gravitational acceleration
or

Condition 1: f ′ (x∗) ≥ 0
Condition 2: x∗ [f ′ (x∗)] = 0
Condition 3: x∗ ≥ 0

(2)

4 ERT Commands

\noindent{}
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4.1 Start Number of an Enumerated List

This example illustrates how you can change the starting number of an enumerated list. Here's a normal
list:

1. The �rst item

2. The second item

And here is a list where by adding [5] as ERT after the number to make the list start from 5.

5 The �rst item

1. The second item

However, this does not change the subsequent numbers. There is also no '.' after the number, you have
to write that manually. In order to change the subsequent numbers, you need to change the value of the
variable that keeps track of the numbers by adding \setcounter{enumi}{5} as ERT. Here's an example:

5. The �rst item

6. The second item

5 Making a new Journal Layout (NOT working)

1. Make copy of article.layout renamed as article-aer.layout

2. Changed - \DeclareLATEXClass{article} To \DeclareLATEXClass[article, > aer.sty]{article (aer)} And
added - Preamble > \usepackage{aer} > EndPreamble > > Better to use "AddToPreamble" here, lest
you accidentally over-write something.

3. Saved article-aer.layout in C:\Program Files\LYX16\Resources\layouts > 4. Open lyx, recon�gure,
exit lyx

6 Various Preamle Commands

1. Instead of equation #, it has #section.#equation � but remember go to Document > Settings... >
Math Options, uncheck "Use AMS math package automatically" and check "Use AMS math package"
instead, and it will work.
\numberwithin{equation}{section}

2. Instead of just �gure #, make #section,#�gure �
\numberwithin{�gure}{section} % #section.#equation

3. ragged right (unjustied) output �
\usepackage{ragged2e}
\RaggedRight

4. Font 12, article � \documentclass[12pt,english]{article}
or just do Document . Settings .Fonts

5. To make the MS-Word type margins5��
\usepackage{geometry}
\geometry{verbose,letterpaper,tmargin=2.54cm,bmargin=2.54cm,lmargin=3.17cm,rmargin=3.17cm}

6. Or simpler, just go to document>setting>page margins and set top,bottom, inner and outer to 1 inch.
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7. to increase the space between a bullet and the text that follows?
\addtolength{\leftmargini}{3ex}
\addtolength{\labelsep}{3ex}
change 3ex to whatever amount of space you want).

8. In order to use standard article layout, but also have De�nition, Proof, Axiom... add to the preamble
%Building Descriptions
\@ifunde�ned{theoremstyle}{\usepackage{amsthm}}{} \theoremstyle{plain}
\newtheorem{thm}{Theorem}[section]
\theoremstyle{de�nition}
\newtheorem{de�nition}[thm]{De�nition}

\theoremstyle{proof}
\newtheorem{proof}[thm]{Proof}
%end of Building Description

9. to change to roman enumeration, add in preamble. NOTE that you still see in lyx editor 1.2.3..., but
in pdf output as i. ii. iii.

%\renewcommand{\ labe lenumi }{\roman{enumi } .} %\renewcommand{\ labe l enumi i }{\ alph { enumii } . }

will give you MAIN enumeration as i. and SUB a.

10. however

11. if you want i.) and a.) - the parenthesis ), then add

12. \renewcommand{\ labe lenumi }{\roman{enumi } . ) } \renewcommand{\ labe l enumi i }{\ alph { enumii } . ) }

13. Normally we have
1. Section 1.1 subsection 1.1.1subsubsection
but you want to get
1) Section 1.1) subsection 1.1.1) subsubsection

(a) You need to rede�ne the macros:
\thesection, \thesubsection, and \thesubsubsection, e.g.:

\newcommand\mysection {\ arab i c { s e c t i o n }} \renewcommand\ th e s e c t i on {\mysection )} \newcommand\mysubsection {\mysection . \ a rab i c { subse c t i on }} \renewcommand\ the subs e c t i on {\mysubsection )} \newcommand\mysubsubsection {\mysubsection . \ a rab i c { subsubsec t ion }}
\renewcommand\ thesubsubsec t i on {\mysubsubsection )}

6.1 changing how Section, Subsections etc. look like

Here, we change the default article large/bold to large/italics.

\renewcommand{\ s e c t i o n }{\ @s ta r t s e c t i on
{ s e c t i o n }% % the name
{1}% % the l e v e l
{0mm}% % the indent
{−\baselineskip}% % the be f o r e s k i p
{0 .5\ baselineskip}% % the a f t e r s k i p
{\ normalfont \ l a r g e \ i t shape }} % the s t y l e

or here section is bold normal and subsection is italic normal.
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\renewcommand{\ s e c t i o n } {\ @s ta r t s e c t i on
{ s e c t i o n}% % the name
{1}% % the l e v e l
{0mm}% % the indent
{−\ba s e l i n e s k i p}% % the be f o r e sk ip
{0 .5\ b a s e l i n e s k i p}% % the a f t e r sk ip
{\ normalfont \ b f s e r i e s }} % the s t y l e

\renewcommand{\ subse c t i on } {\ @s ta r t s e c t i on
{ subs e c t i on}% % the name
{1}% % the l e v e l
{0mm}% % the indent
{−\ba s e l i n e s k i p}% % the be f o r e sk ip
{0 .5\ b a s e l i n e s k i p}% % the a f t e r sk ip
{\ normalfont \ i t shape }} % the s t y l e

7 Presentation (using Beamer)

7.1 General

Super Easy.
Document>document class> scroll down to �nd 'beamer presentation'
Use on the left hand side: beginframe, endframe. Part, section, subsection.
In preamble place:
\usetheme{Warsaw}
I'm using now
\usetheme[hideothersubsections]{Hannover}

Not necessary - extra
%\usecolortheme{seahorse}
%\usecolortheme{rose}
% seems to �x typewriter font in outline header:
%\usepackage{ae,aecompl}

Lots of presentation styles:

1. \usetheme{Berlin}

2. \usetheme{Warsaw}

3. \usetheme[hoptionsi]{Marburg}

4. \usetheme{boadilla}

See in the website, www.ctan.org, a pdf �le of: �The beamer class Manual for version 3.07.�

7.2 Page number

various ways

� plug in preamble.

\setbeamertemplate{footline}[text line]{\insertframenumber}

� If using a theme like Warsaw

� In beamer slides, this will give you slide/total slide.
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� go to left side of the title, go to insert>short title which opens a box opt

� in opt box plug in for example slide texmode inserframenumber / texmode \inserttotalframenumber

� or copy paste the following which will not be seen in pdf printout (plug and play) TITLE

7.3 Tex Code for Beamer

7.3.1 De�ning a Slide

Here is how to de�ne a slide
\begin{frame}
\frametitle{A title}
Some content. bla bla bal
\end{frame}

7.3.2 Printing a few slides on one page for handout

In preamble plug in
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]

7.3.3 Deleting/suppressing frames

Sometimes you want to have slides present in the presentation, but not in the handout.
In order to print a handout (suppress some slides) you place the following command in TEX mode.
For suppressing a frame, do the following:
Write in TEX

\begin{frame}<handout:0>
\frametitle{A title}
Some content. bla bla bal
\end{frame}

THEN
Go to document>setting>in custom write handout.
Don't forget to delete it if you want a presentation with all slides included!!

7.3.4 Pause

In TEX, at the end of the bullet, write \pause, or in the side drop-down box, use the pause function. But
this makes too many marks in LYX. I like the clean tex \pause.

7.4 Handouts in Beamer

7.4.1 To have some slides NOT appear in your handouts, you do the following:

� those slides that I would like NOT to appear in a handout, I use TEX and write

\begin{frame}<handout:0>
\frametitle{bla bla bla - here is the title}

� then, when I'm ready to see handouts, I go to setting>custom> type-in handout
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7.4.2 To print 2 or 4 slides in one sheet I add in the preamble:

%TO PRINT A FEW SLIDES ON ONE PAGE
\usepackage{pgfpages}
\pgfpagesuselayout{2 on 1}[a4paper,border shrink=5mm]
%\pgfpagesuselayout{4 on 1}[a4paper,border shrink=5mm]

� But so far, only 2 slides come out nice. 4 slides is too small. I don't know why.

7.4.3 Not tested: Beamer background image on one slide only

You need
ERT
box{\usebackgroundtemplate{\includegraphics[width=\paperwidth] {/home/graham/Dropbox/Lectures/R-

Intro/Images/Moon.png}}
Then the begin frame menu item
Frame content
Then end frame menu item
Then an ERT box with }

7.5 Adding a box in Beamer

\ begin { block }{ t i t l e o f box }

� some text

8 Hebrewpage

NOT TESTED

� XeTEX instead of LATEX for Hebrew because it allows to use any font installed the sytem.

� If you type in unicode (utf8) and use a unicode font, this works well.

In your preamble put this:
\usepackage{fontspec}
\usepackage{xltxtra}
\usepackage{bidi}
\newfontfamily\hebrewfont[Script=Hebrew]{<your font installed on your system>}
\newenvironment{hebrew}{\setRL\hebrewfont}{\setLR}
\newcommand{\he}[1]{\RL{\hebrewfont #1}}
To include Hebrew, type:
\he{<Hebrew text>}
or
\begin{hebrew}
<Hebrew text>
\end{hebrew}
Biblical Hebrew is SBL Hebrew, but you can choose any font on your system when you compile with

XeTEX. Google for how to set up LYX to use XeTEX. It's not that complicated.
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