Skip to main content

Supported browsers

Servers on Demand is supported on the following browsers;

  • Microsoft - IE8 or newer (Compatibility mode for IE8, IE9 and IE10 is not supported. Using compatibility mode can cause blank pages.)
  • Google - Chrome 29 and newer
  • FireFox - Firefox 23 and newer